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This document is designed to help get you started using the Interact program. The manual 
is divided into the following sections: 

 Getting Started 

 Translation 

 Configuration 

 Users 

 Visualize 

 ComposerEditor 
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Contact Technical Support................................................................................ 2 
Contact Sales....................................................................................................... 2 
 
 

About ComposerEditor 
Composer Editor™ is a language translation program that operates on a desktop PC. 
Composer Editor serves as the single‐source maintenance solution for updating dictionary 
files used by Interpreter™. 
 

How does ComposerEditor work? 

ComposerEditor allows you to create new or edit existing dual‐language dictionary files. By 
using ComposerEditorʹs form‐based editing tools, you can easily update terms and 
translations using your desktop keyboard. In addition to basic editing capabilities, you can 
also import and export new terms and phrases from other Compadre™ dictionaries. 
 

Who should use ComposerEditor? 

ComposerEditor is designed for multi‐lingual users who have the ability to read text in both 
the source and target languages. 
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Contact Technical Support 

Contact Customer Support if you have questions about how to use this application or if 

you are experiencing technical difficulties. 

Start with the web site. There are FAQ and Release Notes that may have your question 

answered. 

1) Web: SpeechGear support web site (http://www.speechgear.com/support.aspx) 

2) E-mail: support@speechgear.com (mailto:support@speechgear.com) 

 
 

Contact Sales 

To help us improve our products, we encourage you to provide us with feedback about this 

guide or the product. Please contact us with any questions or comments you may have 

regarding this product. 

SpeechGear, Inc. 

1310 Bollenbacher Drive 

Northfield, MN 55057 

E-mail: info@speechgear.com (mailto:info@speechgear.com) 
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Typographical Conventions 
The following kinds of formatting in the text identify special information. 

Formatting Convention  Type of Information 

To . . . Step‐by‐step procedures. You can follow these 
instructions to complete a specific task. 

NOTE:  Tips or special instructions. 

Special Bold  Denotes a description or a menu option or label. 

Button 

Denotes actiKey combinations for which you must 
press and hold down one key and then press another, 
for example, CTRL+P, or ALT+F4.on. Refers to items 
you must select, such as menu options or command 
buttons. 

Emphasis 

Used to emphasize the importance of a point or for 
variable expressions such as parameters. 

or 

Identifies a dialog box, tab, or other interface item. 

CAPITALS 
Names of keys on the keyboard. for example, SHIFT, 
CTRL, or ALT. 

KEY+KEY 
Key combinations for which you must press and hold 
down one key and then press another, for example, 
CTRL+P, or ALT+F4. 
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System Requirements 

Required Hardware 
 Desktop PC 

 Pocket PC* 

 Pocket PC cradle* 

 USB connection port and cable* 

NOTE: *Only required for Interpreter application when working with dictionary files 
resident on the device. 

 
 

Required Software 
 PC Platform Operating System: Windows® XP, or Vista 

 Pocket PC Platform Operating System*: Windows Mobile 2003, Mobile 5.0 or Mobile 6.0 

 .NET Framework: 1.1 or later version 

NOTE: The .NET Framework is a component of the Microsoft® Windows® operating 
system used to build and run Windows‐based applications. The Composer setup file 
will alert you if you do not have .NET Framework installed. Visit Microsoftʹs .NET 
Framework http://msdn.microsoft.com/netframework/technologyinfo/howtoget/ home 
page to install the latest version. 

 Microsoft ActiveSync*: 3.5 or later version 

NOTE: ActiveSync® is synchronization software for Microsoft Windows® Powered 
Pocket PCs. You need ActiveSync® in order to transfer files to and from your Pocket 
PC. 
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Installing ComposerEditor 
SpeechGear, Inc. provides you with a Compadre:ComposerEditor™ setup and installer 
package when you purchase the software. Locate the Setup.exe file to begin. 

The setup wizard will guide you through the installation process for copying the files onto 
your hard disk. If you already have ComposerEditor installed, you will find the program in 
your Start > All Programs > SpeechGear > ComposerEditor menu. 

To install Compadre:ComposerEditor™ 

1) Open the Setup file. 

The Compadre:ComposerEditor™ setup wizard launches. 

2) Click Next. 

The Program Icons screen appears. 

 Place Icon on Desktop: Check the box if you want a shortcut to ComposerEditor on 
your desktop after successful installation. 

 Place Icon in Start Menu: Check this box if you want a ComposerEditor icon in 
your Start menu after successful installation. 

3) Click Next. 

The Select Installation screen appears. 

 Browser: Click to choose a different installation folder than the suggested folder. 

 Disk Cost: Click to view the available installation drives and their available and 
required disk space. 

 Everyone/Just Me: Choose your preferred privacy options. 

4) Click Next. 

The Confirm Installation screen appears. 

5) Click Next. 

The program will copy the files to your hard disk at the location specified. The License 
screen appears. 

6) Read the license instructions, and then click Next. 

7) Click Close to complete the wizard setup. 

Depending on your Program Icons preferences, a ComposerEditor shortcut may appear 
on your desktop and/or in your Start menu. 
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Starting ComposerEditor 
To launch ComposerEditor 

From your desktop, either click Start > All Programs > SpeechGear > ComposerEditor or 
double‐click the ComposerEditor shortcut. 

 

The Start window appears. 

 

 
 

Understanding the ComposerEditor Interface 
The ComposerEditor interface will vary depending on the type of dictionary you are 
working with. All features are listed below. 
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Main Window 

ComposerEditorʹs Main window* provides the tools for creating and/or editing your 
translation data. This window contains the following features: 

   

NOTE: *The Main window will contain a Translation Memory menu item in place of the 
Dictionary menu item when working with Translation Memory dictionaries. 

 
 

File menu: 

Contains all dictionary file functions: 

 New (  ): Creates a new Interpreter Dictionary. 

 Open Local (Ctrl + O  ): Opens an existing dictionary file (.idct) stored on your local 
system or on a connected mobile device. 

 Save (Ctrl + S  ): Saves the current dictionary file to your local system. 

 Save As: Saves a copy of the current dictionary file to your local system. 

 Close: Closes the current dictionary file. ComposerEditor prompts you with saving 
options before closing any unsaved files. 

 Close All: Closes all open dictionary files. ComposerEditor prompts you with saving 
options before closing any unsaved files. 

 Open Database: Opens a connection dialog box. 

 Pocket PC Device: Saves an existing file to a connected mobile device or loads a file 
from a connected device. 

 Recent Documents: Lists the last five files opened during the current session. Choosing 
a file from the Recent Documents list saves loading time. 

 Exit (ALT + F4): Safely closes the ComposerEditor program. 
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Edit menu: 

Contains all text edit options: 

 Undo Add Entry (Ctrl + Z  ): Removes the last editing operation. 

 Redo (Ctrl + Y  ): Redoes the last editing operation. 

 Cut (Ctrl + X  ): Cuts the current selection of text. 

 Copy (Ctrl + C  ): Copies the current selection of text. 

 Paste (Ctrl + V  ): Pastes the last selection of text. 

 Delete: Deletes the selected item from the dictionary.   

 
 

Dictionary menu: 

Contains all dictionary editing options: 

 New Category: Adds a new category to the active dictionary. 

 New Entry: Adds a new entry to a selected category. 

 New Translation: Adds a new translation to a selected entry. 

 New Favorites List: Adds a new favorites list to the active dictionary. 

 
 

Tools menu: 

Contains all search and import options: 

 Go to (CTRL + G): Provides search‐as‐you‐type functionality; locates the closest 
matching word or phrase within the current category. 

 Find (CTRL + F): Searches for a key word in the active dictionary. 

 Replace (CTRL + H): Globally replaces all instances of a selected word. 

 Filter: Allows you to populate a new dictionary using only the entries composed by a 
selected author or authors. 

 Import: Provides import functionality; allows you to choose a source file and merge 
duplicate terms with or overwrite the selected target file. 

 Export: Provides export functionality; allows you to export a dictionary into a 
tab‐delimited document. 

 
 



 

10  ComposerEditor for Interpreter Userʹs Guide 
 

Window menu: 

Contains window display options: 

 Cascade: Stacks all open dictionary windows in a diagonal order. 

 Tile Horizontally: Stacks all open dictionary windows top‐to‐bottom. 

 Tile Vertically: Stacks all open dictionary windows side‐by‐side. 

 Minimize All: Minimizes all open dictionary windows; the main window becomes the 
active window. 

 Maximize All: Maximizes all open dictionary windows. 

 
 

Help menu 

Contains the ComposerEditor About and Help files. 
 

Dictionary Window 

The Dictionary window is used to create and/or edit contents of your dictionaries. This 
window contains the following features. 
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 Title bar: Displays the current file name and the file directory to which it is saved (if 
any). 

 Category list: Displays all categories in the selected dictionary. 

 Entry list: Displays all dictionary entries in the selected category list. 

 Translation entry: Displays a translation for a selected dictionary entry. 

 Usage Sample entry: Displays a usage sample for the selected entry. For example, you 
can specify gender‐specific terms with an m or f (male/female, respectively). You can 
also include usage samples within the actual translation entry (i.e. ʺmanzana ‐ (f)ʺ). 
Some examples appear below: 

 n (noun): Express persons, places, and things. 

 v (verb): Express action, an occurrence, or state of being. 

 pers. pron (personal pronoun): Substitutes for nouns. 

 a (adjective): Describes nouns. 

 speed (adverb): Modifies verbs, adjectives, or other adverbs. 

 proximity (preposition): Joins nouns and pronouns; show relationships between 
objects and prepositions. 

 conjunction: Connects words or groups of words. 

 interjection: Express strong feelings. 

 Author entry: Displays the author name for the selected translation entry. 
ComposerEditor enforces inherent authors based on the program or source used to 
create or edit an entry. You can create or rename an author when you update a 
translation entry. 

 Composer: Denotes an entry created or edited in ComposerEditor. 

 SpeechGear: Denotes an entry created or edited an original dictionary file from 
SpeechGear. 

 PDA: Denotes an entry created or edited in Interpreter™. 

 Favorites list: Displays all favorites lists in the selected dictionary file. 

 Source entry: Displays a copy of a dictionary entry that has been added to a favorites 
list. Changes you make to a dictionary entry that is also a member of a favorites list 
does not update the source entry. 

 Source category: Displays the category of the selected source entry. The source 
category appears by default when a source entry is added. Changes you make to a 
dictionary category that is also a favorites list does not update the source category. 
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Changing the Window Display 
ComposerEditor allows you to open multiple dictionaries at the same time. This is useful 
when you are comparing the contents of dictionaries. The Window display options allow 
you to manage your preferences for viewing these multiple dictionaries. 

To change the window display 

1) Start ComposerEditor. (Start > All Programs > SpeechGear > ComposerEditor) 

2) Click Window, and then click the option you want to use. 

   
 Cascade: Stacks all open dictionary windows in a diagonal order. 

 Tile Horizontally: Stacks all open dictionary windows top‐to‐bottom. 

 Tile Vertically: Stacks all open dictionary windows side‐by‐side. 

 Minimize All: Minimizes all open dictionary windows; the main window becomes 
the active window. 

 Maximize All: Maximizes all open dictionary windows. 

 
 

Using Search 
ComposerEditor provides you with two ways in which to a look for words and phrases 
within a dictionary: Go to and Find. You can also use the Replace feature to insert 
replacement text for a search term. 

To use Go To 

1) Start ComposerEditor, and then open a dictionary. 

2) Click Tools > Go To (or CTRL + G). Opens the Goto dialog box. 
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3) Enter the word or phrase for which you are looking. As you type, the Goto feature will 
select the closest matching term within the current category. 

 

To use Search 

1) Open a dictionary. 

2) Click Tools > Find (or CTRL + F). 

The Search screen appears. 

 Search For: Enter a search term. 

 In: Displays the dictionary upon which the search is being conducted.  

 Search in Phrase: Check this box to return search results that only contain the 
search term in a dictionary entry. 

 Search in Translation: Check this box to return search results that only contain the 
search term in a translation entry. 

 Search Whole Entry: Check this box to return search results that contain the search 
term in a dictionary entry, translation, and/or usage sample. 

 Ignore case: Check this box to return search results that appear in both lower‐ and 
upper‐case. If unchecked, ComposerEditor will only return search results that 
appear in the same case as entered in the Search box. 

3) Click Search. 

The entries that match your selected criteria appear in the results list. The number of 
matches appears in the bottom, left corner of the Search screen. 

4) Click a search result record to locate the matching dictionary entry. 

 
 

Replacing Text 
ComposerEditor allows you to automatically replace text that appears in a dictionary or 
translation entry. For example, you can replace ʺAcmeʺ with ʺApexʺ without manually 
editing each record that contains the term. You can replace all entries that contain a 
selected term at one time, or you can replace individual entries. 

To replace text 

1) Start ComposerEditor and open a dictionary. 

2) Click Tools > Find (or CTRL + F). 

3) The Search screen appears. 

4) Enter the text you want to replace in the Search For box. 
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5) Enter the text with which you want to override the search term in the Replace With 
box. 

6) Click Search. All matching entries appear in the Results list. 

 
7) Select the entry you want to replace. 

 You can select multiple entries by holding the CTRL key down as you click. 

 You can replace all matching entries by using the Replace All button. 

8) Click Replace. 

All selected entries are replaced with the text you entered. 

NOTE: If the Replace button is dimmed, make sure you have at least one entry selected 
in the Results list. 

9) Click Close. 
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When you want to edit or create a dictionary used in the Interpreter application, use the 
Interpreter Dictionary features in ComposerEditor. These features are specific for the 
Interpreter application and allow you to maximize editing capabilities and connection 
options with your Pocket PC such as connecting directly to a mobile device to edit files and 
building favorites lists and phrases that are only supported with Interpreter. 

This section will walk you through the process of using ComposerEditor to open a new 
dictionary, add new terms, and save a dictionary to a connected device. When you are 
finished editing in ComposerEditor, you will also find instructions for loading the new 
dictionary into the Interpreter application. 
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Creating a New Interpreter Dictionary 
Creating a new dictionary will open a blank Dictionary window. 

To create a new Interpreter Dictionary 

1) Create a new Interpreter Dictionary in either of two ways: 

2) From the Main window, click File > New > Interpreter Dictionary. 

3) Click the    icon. From the Open window, select Interpreter Dictionary, and click 
Open. 

Chapter 3 

Using ComposerEditor for Interpreter 
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A blank Dictionary window appears. 

 

NOTE: ComposerEditor issues Interpreter Dictionary file a temporary name (i.e. 
Untitled ‐ #) until you save the file. 

 

Opening an Interpreter Dictionary 
ComposerEditor allows you to open existing Interpreter Dictionary files (.idct) from both 
local and device systems. 

NOTE: A local system location displays existing directories on your desktop PC. A device 
system location displays existing directories on a connected mobile device. For example, if 
you have a Pocket PC synchronized with your desktop PC, you can open files directly from 
the Pocket PC device. 

Valid dictionary files must use the following naming convention: 
<source language><2><target language>. 

 Valid file example: English2Spanish.idct 

 Invalid file example: English2English.idct 

 Invalid file example: EnglishandSpanish.idct 

To open an Interpreter Dictionary from a local system 

1) From the Main window, click File > Open (or click the    icon).   

2) On the Open window, select Interpreter Dictionary, and then click Open. 



 

  Chapter 3       Using ComposerEditor for Interpreter  17
 
 

The Open Dictionary window appears. 

 
3) Locate the dictionary file you want to open. 

4) Click Open. 

5) Wait for ComposerEditor to load the dictionary in a new dictionary window. 

NOTE: You can also open a file in the Recently Opened Files box. (From the Main window, 
choose File > Recent Dictionaries.) Choosing a file from the Recent Dictionaries list saves 
loading time. 

 

To open an Interpreter dictionary from a connected device 

1) From the Main window click File > Pocket PC Device > Open From Device. 

The Open Dictionary From Device window appears. All directories on the Pocket PC 
are listed. 

NOTE: If your device is not connected properly, the system will not be able to connect 
and may remain idle. Connect your device and try again. 

2) Locate the dictionary file (.idct) you want to open. 

NOTE: Click the folder you want to explore. Click +    to expand a folder; click ‐    to 
collapse a folder. 

3) Click Browse to choose a local storage directory in which to save the file. 

The Browse For Folder window appears. 
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NOTE: You must choose a destination folder on your local system before you can open 
the dictionary. 

 
4) Click OK. 

The Loading Dictionary progress screen appears. When ComposerEditor has finished 
loading, the dictionary appears in a new Dictionary window. 

NOTE: When you are finished editing a Dictionary file from a device, you must save 
the file locally before you can save it back to your device. 
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Importing a Dictionary 
Importing a dictionary allows you to load entries from one Interpreter Dictionary file into 
another Interpreter Dictionary file. Before importing you can choose which categories to 
import and how to handle duplicate entries (overwrite or merge). 

 

You can also import dictionary entries from a tab‐delimited text file. See Tab‐Delimited 
Formatting (below) for examples of acceptable formatting. 

NOTE: Importing a dictionary file cannot be undone. 

To import into an Interpreter dictionary 

1) Open a new or existing target dictionary file. 

2) From the Main window, click Tools > Import.... 

The Import Dictionary Data window appears. 

 Name: Click Browse to locate the source file you want to import. The source file 
must be stored in a local system location. 

 Type: Choose the type of file you want to import (.dict or .txt). 

 Show Selection Form: Select the check box to view a post‐import report to confirm 
changes and avoid importing undesired data. 

 Default Category: (Tab‐delimited text file use only.) Choose a target category in which 
to store source entries that do not specify a category within the text file. 

 Overwrite Matching Entries: Check the box to replace all existing translations with 
translations in the imported file in the event of a duplicate entry. Leave the box 
unchecked to append translations in the imported file to existing translations in the 
event of a duplicate dictionary entry. 

3) Click OK. 

Wait for ComposerEditor to load the dictionary. When the dictionary is loaded, data 
from the source file appears in the corresponding target categories. 
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4) If you chose to view the Selection Form, the Import Results screen appears with a list of 
each category from the imported dictionary. Select the categories and/or entries you 
want to import and clear the check box next to any categories you donʹt want to import. 
In the right panel of the Selection Form, ComposerEditor shows you the original and 
existing translations for each entry. Select the ones you want to keep. 
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Tab-Delimited Formatting 

You can import a tab‐delimited file the same way in which you import a dictionary file. The 
tab‐delimited file must follow the formatting examples shown below. 

[<category name>] 

<source><tab><target>[<tab><usage sample>]<new‐line> 

NOTE: Data shown within square brackets is optional. 

To include more than one translation per entry, you must include tabs and a space‐holder 
for a usage sample between the translations. Separate multiple usage samples with a 
semicolon. 

The following example shows a text file with sample English‐to‐Spanish dictionary entries 
created using Windows® Notepad. You can also use Microsoft® Excel or other spreadsheet 
application to create tab‐delimited files. 

 

NOTE: ComposerEditor imports data exactly as listed. For example, the terms ʺbusʺ and 
ʺboatʺ will not be alphabetized when imported into ComposerEditor. 
 

Filtering a Dictionary 
Filtering a dictionary allows you to populate a new dictionary using only the entries 
composed by a selected author or group of authors. 

To filter a dictionary 

1) Open a new or existing dictionary file. 

2) From the Main window, click Tools > Filter.... 
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The Filter Dictionary window appears. 

 
3) Select the author(s) by which you want to filter. 

4) Click Create New Dictionary. 

A new dictionary opens that contains all the entries composed only by the selected 
author(s). 

5) Click Cancel when finished. 

 
 

Editing Interpreter Dictionaries 
ComposerEditor uses right‐click commands to display all editing menus. ComposerEditor 
also supports drag and drop functionality to transfer entries to other lists. 
 



 

  Chapter 3       Using ComposerEditor for Interpreter  23
 
 

Using a Category 

Categories contain groups of similar dictionary entries. In general, there are three types of 
categories: 

 [Modifiers]: categories that contain modifiers (surrounded by brackets), which are used 
to build custom phrases using Interpreterʹs PhraseBuilder technology. See Using 
Modifiers (on page 33) for details. 

 <Phrases>: categories that contain related phrases (sentences). 

 Words: a single category that contains all words. 

NOTE: Your dictionary does not require these example categories. When loading a 
dictionary to Interpreter, the system will load the category that contains the most entries to 
the ʺWordsʺ tab; all other categories will be loaded to the ʺPhrasesʺ tab. 

In addition, there must be a corresponding category in the reverse dictionary with an 
accurate translation, for example Spanish = ʺPalabrasʺ = ʺWordsʺ. 

You can create new or edit existing categories as needed. All categories must have a unique 
name. You cannot duplicate category names. 

After you add entries to a category, you can change viewing options as well as add entries 
to a favorites list. 

 

To create a new category 

1) Move your mouse pointer over the category list, and then right‐click. 
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A pop‐up menu appears. 

 
2) Left‐click New.... 

The New Category window appears. 

3) Enter a name for the new category, and then click OK. 

The new category appears as the active selection in the list. 

 

To rename a category 

1) Click the drop‐down arrow in the category list to locate the category you want to 
rename. 

2) Select the category, and then right‐click the category name. 

A pop‐up menu appears. 

3) Left‐click Rename.... 

4) The Rename Category window appears. 

5) Modify the category name as needed, and then click OK. 

The category appears as the active selection in the list. 

 

To delete a category 

1) Click the drop‐down arrow in the category list to locate the category you want to 
delete. 

2) Select the category; then right‐click the category name. 

A pop‐up menu appears. 

3) Left‐click Delete. 

A Delete Confirmation window appears. 

4) Click OK. 

The category and all of its contents are permanently removed from the dictionary. 
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To change viewing options 

NOTE: You must have at least one entry in a selected category in order to change viewing 
options. Viewing entries as a numbered list allows you to create another way of grouping 
selected terms. Numbered list terms appear at the beginning of the list; all other terms are 
organized alphabetically after the last numbered item. See Editing Entries (see ʺUsing an 
Entryʺ on page 28) to change viewing options for individual entries within a category. 

 

1) Click the drop‐down arrow in the category list to locate the category you want to 
change. 

2) Select the category, and then right‐click the category name. 

A pop‐up menu appears. 

3) Left‐click View as numbered list. All entries in the category refresh as a numbered list. 
(Click View as alphabetical list to change the list back.) 

 

To add a category to a favorites list 

1) Click the drop‐down arrow in the category list to locate the category you want to add. 

2) Select the category, and then right‐click the category name. 

A pop‐up menu appears. 

3) Left‐click Add to favorites. 

A copy of the entire source category appears in the favorites list area as a new list. 
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Using a Dictionary Entry 

Dictionary entries consist of words or phrases and their corresponding target language 
translations. Each entry must belong to a category and contain at least one translation. 

You can create new or edit existing entries as needed. You can also change viewing options 
and add entries to a favorites list. 

 

To create a new entry 

1) Move your mouse pointer over the entry list, and then right‐click. Opens a pop‐up 
menu. 

2) Left‐click New.... 

The New Entry window appears. 

 Author: Displays the author name for the selected translation entry. Composer 
enforces inherent authors based on the program or source used to create or edit an 
entry. Composer denotes an entry created or edited in Composer. SpeechGear denotes 
an entry created or edited in an original dictionary file from SpeechGear. PDA 
denotes an entry created or edited directly in Interpreter using a PDA. 

 Category: Choose the category to which you want to add the new entry. 

 Original: Enter a new word or phrase for the selected entry. Right‐click within the 
box to insert a modifier Using Modifiers (on page 33) (on page 34). 

 Translation: Enter a corresponding translation in the target language. Right‐click 
within the box to insert a modifier Using Modifiers (on page 33) (on page 34). 

 Usage Sample: Enter a usage sample for the selected entry. For example, you can 
specify gender‐specific terms with the letters m or f (male/female, respectively), or 
you can specify context with the letters n, v, a (noun/verb/adjective, respectively). 
See Understanding the Composer Interface (on page 7) for more examples. 
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3) Click OK. The new entry appears as the active selection in the list. 

 

To rename an entry 

1) Locate the entry you want to rename, and then right‐click. 

A pop‐up menu appears. 

2) Left‐click Rename.... 

The Rename Entry window appears. 

3) Modify the entry name as needed, and then click OK. 

 

To delete an entry 

1) Locate the entry you want to delete, and then right‐click. 

A pop‐up menu appears. 

2) Left‐click Delete. 

A Delete Confirmation window appears. 

3) Click OK. 

 

To copy and paste an entry 

1) Locate the entry you want to copy, and then right‐click. 

A pop‐up menu appears. 

2) Left‐click Copy. 

3) Choose a different category in which to paste the entry. 

4) Click Paste. 

 

To change viewing options 

NOTE: You must have at least one entry in a selected category in order to change viewing 
options. 

1) Locate the entry you want to change, and then right‐click. 

A pop‐up menu appears. 

2) Left‐click View as numbered list. The selected entry refreshes as a numbered list. 
(Click View as alphabetical list to change the entry back to an alphabetical list.) 
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To add an entry to a favorites list 

1) Locate the entry you wan to add, and then right‐click. 

A pop‐up menu appears. 

2) Left‐click Add to favorites. 

A copy of the source entry and category appears in the favorites list as a new list. 

 
 

Using a Translation 

ComposerEditor allows users to you to enter multiple translations for an entry. That way, 
you can select the best translation at the time of need depending on the context of the 
situation. For example, a different translation may be desired if you are talking to a group 
of people instead of an individual person. In addition, you can also provide a usage 
description for each entry to determine the context in which the translation should be used. 

You can create new or edit existing translations as needed. You can also change the order in 
which they appear as well as add a translation—and its corresponding entry—to a favorites 
list. 

 

To create a new translation 

1) Locate the entry to which you want to add the translation. 

2) Right‐click in the translation list. 

A pop‐up menu appears. 

3) Left‐click New.... 

The New Translation window appears. 

 Author: Displays the selected author name for the entry. ComposerEditor creates 
an authoring (.author) file for each saved dictionary file. ComposerEditor enforces 
inherent authors as listed in the authoring file. To rename or create a new author, 
right‐click inside the Author box. 

 Category: Choose the category to which you want to add the new entry. 
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 Original: Enter a new word or phrase for the selected entry. 

 Translation: Enter a corresponding translation in the target language. Translation 
entries support parentheses and dash characters. 

 Usage Sample: Enter a usage sample for the selected entry. For example, you can 
specify gender‐specific terms with the letters m or f (male/female, respectively), or 
you can specify context with the letters n, v, a (noun/verb/adjective, respectively). 
See Understanding the Composer Interface (see ʺUnderstanding the 
ComposerEditor Interfaceʺ on page 7) (on page 7) for more examples. 

NOTE: You can also include usage samples within the actual translation entry (i.e. 
ʺmanzana ‐ (f)ʺ). 

4) Click OK. The new translation appears as the active selection in the list. 

 

To edit a translation 

1) Locate the translation entry you want to change, and then right‐click. 

A pop‐up menu appears. 

2) Left‐click Edit.... 

The Edit Translation window appears. 

3) Modify the translation properties as needed, and then click OK. 

The translation appears as the active selection in the list. 

 

To delete a translation 

NOTE: Every entry must have at least one translation; you cannot delete a translation if it is 
the only one in the list. You may want to delete the entry instead. 

1) Locate the translation entry you want to delete, and then right‐click. 

A pop‐up menu appears. 

2) Left‐click Delete. 

A Delete Confirmation window appears. 

3) Click OK. 

The translation is permanently removed from the dictionary. 

 

To change sort order 

1) Locate the translation entry you move; then right‐click. 
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A pop‐up menu appears. 

2) Left‐click Move up or Move down. The translation moves accordingly. 

You can also sort entries by translation, by usage sample, or by author. Click the title 
bar by which you want to sort. 

 

 

To add a translation to a favorites list 

1) Locate the translation you want to add, and then right‐click over the entry you want to 
add. 

A pop‐up menu appears. 

2) Left‐click Add to favorites. A copy of the complete entry including all translations 
appears in the favorites list as a new list. 

 
 

Using a Favorites List 

Favorites lists allow you to easily keep track of your most frequently used words and 
phrases. You can create multiple favorites lists that can store word and phrase 
combinations. You can create new or edit existing favorites lists as needed. 

To create a new favorites list 

1) Move your mouse pointer over the favorites drop‐down list, and then right‐click. 

A pop‐up menu appears. 

 
2) Left‐click New.... 

The New Favorites List screen appears. 

3) Enter a name for the favorites list. The name must not be the same as an existing list. 

4) Click OK. The new list is the active selection. 

 

To rename a favorites list 

1) Select the list you want to rename, and then right‐click. 

A pop‐up menu appears. 
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2) Left‐click Rename.... 

The Rename Favorites List window appears. 

3) Modify the name as needed. The name must not be the same as an existing list. 

4) Click OK. The new list name is the active selection. 

 

To add source entries to a favorites list 

1) Select the favorites list to which you want to add source entries. 

2) Locate the category or entry you want to add, and then right‐click. 

A pop‐up menu appears. 

3) Left‐click Add to favorites. A copy of the source entry and category appears in the 
selected list. 

 

To change sort order of entries in a favorites list 

1) Select the favorites list you want to change. 

2) Click the title bar by which you want to sort: Source Entry or Category. 

 
The entries move accordingly. 

 

To delete a source entry from a favorites list 

This action deletes a single entry from the selected favorites list. 

1) Select the source entry you want to delete, and then right‐click. 

A pop‐up menu appears. 

2) Left‐click Delete. 

A Delete Confirmation window appears. 

3) Click OK. The source entry is removed from the favorites list. 

 

To delete all source entries from a favorites list 

This action deletes all entries but saves the selected favorites list. 

1) Select the source entry you want to delete, and then right‐click. 

A pop‐up menu appears. 
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2) Left-click Clear. 

A Delete Confirmation window appears. 

3) Click OK. All source entries are removed from the list. 

 

To delete a favorites list 

This action deletes the list and all source entries within the list. 

1) Select the list you want to delete, and then right-click. 

A pop-up menu appears. 

2) Left-click Delete. 

A Delete Confirmation window appears. 

Click OK. The list and all of its contents are removed from the dictionary. 
 

Building Phrases 

In addition to static phrases listed as is in each category, Interpreter allows you to 

customize phrases using modifiers and place-holders. 
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Using Modifiers 

Imagine you are using Interpreter to translate the phrase, "I will be here until one o'clock." 

Instead of adding this phrase to the dictionary as is, you can insert the modifier [quantity] 

in place of the "one". In doing so, when you use Interpreter, you can use this same phrase to 

state any time of day, such as, "I will be here until six o'clock".  

In ComposerEditor, you can create any number of modifier categories to suit your 

language needs. This powerful feature allows you to build phrases that state exactly what 

you want translated. Modifier category names must be surrounded by an opening and 

closing bracket: [modifier name]. Some examples of modifiers are provided below. You 

can create modifier categories specific to your needs. 

� [direction]: north, south, east, west 

� [month]: January, February, March, etc. 

� [quantity]: 1, 2, 3, 4, etc. 

� [color]: red, blue, green, white 

The phrase used in the example above is shown in ComposerEditor as "I will be here until 

[quantity] o'clock" where [quantity] is a listing of the hours within a day. 

NOTE: Modifier categories have all of the same functions as standard categories. The 

following steps provide instructions for specific uses of modifier categories. 

To create a new modifier category 

1) Move your mouse pointer over the category list, and then right-click. 

A pop-up menu appears. 

2) Left-click New.... 

The New Category window appears. 

3) Enter a name for the modifier category surrounded by brackets. For example, 

[quantity].  

4) Click OK. 

The new category appears as the active selection in the list. 

5) Add modifier entries to the modifier category using standard entry editing functions. 

For example, "1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12" 
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To create a new modifier category that uses an ordered list 

The contents of a modifier are by default displayed in alphabetic order. There are instances 

where a different ordering is desired. For example, the months of the year should be listed 

as January, February, March, etc. instead of alphabetically. To do this, when you create the 

modifier, use a number to designate the order in which the modifier's entries should be 

displayed. So, the entries for the months of the year would be entered as the following: 

1. January 

2. February 

3. March 

4. April 

. . . and so forth.  

To create a new phrase that uses modifiers 

1) Move your mouse pointer over the entry list, and then right-click. 

A pop-up menu appears. 

2) Left-click New.... 

The New Entry window appears. 

� Author: Displays the selected author name for the entry. ComposerEditor creates 

an authoring (.author) file for each saved dictionary file. ComposerEditor enforces 

inherent authors as listed in the authoring file; you are not able to change the list 

available authors. 

� Original: Enter a new word or phrase. Right-click within the box to insert a 

modifier. 

� Translation: Enter a corresponding translation in the target language. Right-click 

within the box to insert a modifier. Do not translate the modifier. 

� Usage Sample: Enter a usage sample for the selected entry. For example, you can 

specify gender-specific terms with the letters m or f (male/female, respectively), or 

you can specify context with the letters n, v, a (noun/verb/adjective, respectively). 

See Understanding the Composer Interface (on page 7) for more examples. 
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3) Click OK. The new entry appears as the active selection in the list. When the selected 
dictionary is loaded to Interpreter, you will have the option to build your own phrase 
using the modifiers provided. 

 

 
 

Using Place-Holders 

Imagine you are using Interpreter to translate the phrase, ʺI want to buy a ticket.ʺ Instead of 
adding this phrase as is, you can insert the place‐holder [___] in place of the ʺticketʺ. In 
doing so, when you use Interpreter, you can reuse this phrase at a later time by choosing a 
different word from the Words list; for example, ʺI want to buy a gift.ʺ The place‐holder 
will populate with the most recent word you have selected from the dictionary. 

To create a new place-holder phrase 

1) Move your mouse pointer over the entry list; then right‐click. 

A pop‐up menu appears. 

2) Left‐click New.... 

The New Entry window appears. 

 Author: Displays the selected author name for the entry. ComposerEditor creates 
an authoring (.author) file for each saved dictionary file. ComposerEditor enforces 
inherent authors as listed in the authoring file; you are not able to change the list 
available authors. 

 Original: Enter a phrase for the selected entry. Insert three underscore characters 
surrounded by brackets where you want the placeholder to appear. For example, ʺI 
would like some [          ].ʺ 
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 Translation: Enter a corresponding translation in the target language. Insert three 
underscore characters surrounded by brackets where you want the placeholder to 
appear. 

 Usage Sample: Enter a usage sample for the selected entry. For example, you can 
specify gender‐specific terms with the letters m or f (male/female, respectively), or 
you can specify context with the letters n, v, a (noun/verb/adjective, respectively). 

3) Click OK. 

The new entry appears as the active selection in the list. When the selected dictionary is 
loaded to Interpreter, you will have the option to build your own phrase using the 
available entries in the Words list. 
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Saving a Dictionary 
ComposerEditor allows you to save Dictionary files to both local and device systems. You 
must save the file locally before you can save the file to a connected device. 

 A local system location displays existing directories on your PC. 

 A device system location displays existing directories on a connected mobile device. For 
example, if you have a Pocket PC synchronized with your desktop PC, you can save 
files directly to your Pocket PC. 

 A database system automatically saves when a record is updated; there is no Save 
feature for TM database dictionaries. 

Valid Interpreter Dictionary files must use the following naming convention: 
<source language><2><target language>. 

 Valid file example: English2Spanish.idct 

 Invalid file example: English2English.idct 

 

To save a dictionary to a local system 

1) Click File > Save (CTRL + S). 

The Save Dictionary window appears. 

2) Locate the directory in which to save the file. 

3) Enter a name for the file, and then click Save. 

NOTE: When you save an Interpreter Dictionary, the system also creates a 
corresponding reverse translation file. For example, English2Spanish and 
Spanish2English). 

 

To save a copy of a dictionary to a local system 

1) Click File > Save As. 

2) The Save As Dictionary window appears. 

3) Locate the directory in which to save the file. 

4) Enter a name for the copied file, and then click Save. 



 

38  ComposerEditor for Interpreter Userʹs Guide 
 

 

To save an Interpreter Dictionary to a connected device 

In order for Compadre:Interpreter™ to use a dictionary, a Dictionary folder within the 
Pocket PCʹs program directory that is called ʺEnglish‐[Target Language]ʺ must exist. 
Example: \programfiles\Interpreter\English‐Spanish. There must exist two dictionary files 
within the folder: [source]2[target].idct and [target]2[source].idct. 

1) Click File > Pocket PC Device > Save To Device. 

The Save Dictionary To Device screen appears with a listing of directories on your 
Pocket PC. 

NOTE: If your device is not connected properly, the system will not be able to connect 
and may remain idle. Connect your device and try again. 

2) Locate the directory in which to save the file. 

NOTE: Click the folder you want to explore. Click      to expand a folder; click      to 
collapse a folder. 

3) Click OK. 

Wait for ComposerEditor to copy the file to your device. 

NOTE: If a related Compadre program is running on your device, tap Start > Settings > 
Memory > Running Programs to view the Running Program list. 

 

Loading a Dictionary into Interpreter 

Before you can use a dictionary created in ComposerEditor with Interpreter, you must save 
the dictionary to your Pocket PC system. Make note of the directory in which you save the 
file. 

To choose a dictionary in Interpreter 

1) Start Interpreter on your Pocket PC. 

2) Tap Options > Languages.... 

3) The Language Options window appears. 

4) Tap the drop‐down arrow in the Active Dictionary list, and then select the new 
dictionary to use for translations. 

5) Tap OK. 

Your settings will be saved and you will return to the Words tab. 
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